amdgpu-pro unter KDE neon installieren

KDE neon Community Foren Support Hardware amdgpu-pro unter KDE neon installieren

Dieses Thema enthält 1 Antwort und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Terence vor 4 Monate. This post has been viewed 1289 times

Ansicht von 2 Beiträgen - 1 bis 2 (von insgesamt 2)
  • Autor
    Beiträge

  • WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 140

    Ich hab’ mir jüngst ein paar Hardware-Upgrades gegönnt. Im Desktop werkelt seit letzer Woche eine niegelnagelneue AMD RX460 der Firma XFX mit 4GB GDDR5. Da der 10 Jahre 19” LG Monitor (er wollte einfach nicht kaputt gehen… ;-)) am DVI-Ausgang nicht erkannt wurde, war die Gelegenheit günstig den auch zu ersetzen. Es wurde ein AOC E2275PWQU, der für kleine Münze quasi alle Anschlüsse mitbrachte.

    Da die Situation bei den AMD-Treiber momentan etwas verzwickt ist, war ich um so überraschter, dass der Rechner ohne murren startete und mir den Plasma Desktop in nativer FullHD-Auflösung präsentierte. Der Monitor wurde als “default” ohne Kennung am DisplayPort-Anschluss erkannt, Ton über die integrierten Lautsprecher gab es nicht, beim anstecken eines zweiten Monitors via HDMI, geschah rein gar nichts.

    Die Mühen mich in die aktuelle Standard-Treiber-Logik von Ubuntu 16.04 einzulesen, habe ich an der Stelle gespart. Was da seinen Dienst tat Mesa, quelloffener amdgpu, ist quasi auch egal. Der Desktop war bedienbar, flott, (mit aktuellem Plasma natürlich super hübsch) und man konnte ohne Verränkungen am Ziel-Setup arbeiten.

    Kein Ton am AOC E2275PWQU

    Sowohl über die digitalen Ausgänge HDMI/DisplayPort als auch über die analoge Mini-Klinke spuckte der AOC kein Ton aus. Der Pro Treiber behob das später am digitalen Ende, externe Lautsprecher funktionierten an der Klinke des Mainboards. Wie herausfinden musste, bietet der AOC-Monitor in seinen Einstellungen leider keine Möglichkeit den Eingang des Audio-Signals separat zu wählen, wie man das sonst gewohnt ist. Anscheinend wählt er automatisch beim Anschluss eines digitalen Kabels auch den digitalen Audio-Eingang. Das ist schon irgendwie blöd… vor allem, wenn der Standardtreiber keine digitalen Ton liefert…

    Proprietären amdgpu-pro Treiber installieren

    Ziel war es eh den proprietären amdgpu-pro Treiber installieren zu installieren. Der befindet sich zwar noch in eine (frühen) Betastadium, allerdings stehen damit zusätzliche Funktionen zur Verfügung, wie bspw. die Vulkan-Schnittstelle und eine bessere Energieverwaltung. Bei AMD kann man den Treiber herunterladen und findet zudem eine einfache Installationsanleitung.

    Paket herunterladen, entpacken, Installscript ausführen, fertig… denkste…

    neon@neon-desktop:~/Downloads/amdgpu-pro-driver$ ./amdgpu-pro-install
    Unsupported OS

    Das Installionsskript verweigert den Dienst mit der Meldung “Unsupported OS“. Die Lösung ist aber denkbar einfach. Der Installer prüft in /etc/os-release die ID auf die Strings ubuntu oder steamos.

    Ersetzt man in der Datei “amdgpu-pro-install” in Zeile 46 ubuntu durch neon, läuft die Installation problemlos durch.

    original:

    case "$ID" in
    ubuntu)
    PACKAGES="amdgpu-pro amdgpu-pro-lib32 amdgpu-pro-dkms"

    ändern in:

    case "$ID" in
    neon)
    PACKAGES="amdgpu-pro amdgpu-pro-lib32 amdgpu-pro-dkms"

    Das Skript nutz zur Installation sauber die Paketverwaltung und lief bei mir ohne Fehlermeldung bis zu Ende durch. Der Desktop blieb aber dabei komplett stecken… Den Mauszeiger konnte ich noch bewegen, klicken aber nichts. Die KWin-Shortcuts wurden ebenfalls ignoriert. Ich wollte auch nicht weiter warten und haben das System einfach über tty1 (Strg+Alt+F1) via sudo shutdown -h now heruntergefahren.

    Nach dem Neustart war alles tutti. Der Monitor wurde als 2275W am Displayport erkannt, der Ton funktionierte ebenfalls problemlos. Der zweite Monitor am HDMI war auch da, samt richtiger Kennung. Alle KDE-Spielereien zur Einrichtung und Steuerung von Ton und Bild stehen zu Verfügung.

    Ick freu mir wie bolle über das neue Setup und werd’ heut’ noch munter weiterbasteln.

    • Dieses Thema wurde geändert vor 1 Jahr, 8 Monate von  Neon.
    #402

    Terence

    @terence

    Teilnehmer
    • Beiträge: 25

    Hallo @wills,

    ich möchte mir auch eine größere GK zulegen (momentan 1 GB) bzw. fehlt nur die GK in neuem System und dachte auch an 4 GB AMD.

    Läuft immer noch gut?
    Kannst Du Wayland benutzen?
    Gibt auch eine Wasserkühlung dafür?

    Danke im Voraus und schöne Grüßen, Terence

    #1792
Ansicht von 2 Beiträgen - 1 bis 2 (von insgesamt 2)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.