iSCSi – schaffe es nicht ein Laufwerk einzubinden: iscsiadm: No Records found

KDE neon Community Foren Support Applications iSCSi – schaffe es nicht ein Laufwerk einzubinden: iscsiadm: No Records found

Schlagwörter: , ,

Dieses Thema enthält 2 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  Kali vor 5 Monate, 3 Wochen. This post has been viewed 248 times

Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)
  • Autor
    Beiträge

  • Kali

    @kali

    Teilnehmer
    • Beiträge: 5

    Hallo!

    Erst dachte ich, es liegt an meiner fehlerhaften editirung der CHAP Daten.
    Ich hab auf einem NAS (qnas) mit iscsi zwei Laufwerke freigeben (eines mit CHAP eines komplett ohne zum Testen). Beides klappt nicht. Unter Windows (7 & 10) bekomme ich es einwandfrei hin.

    Bei dem Beispiel wird auf ein Target ohne CHAP versucht zu verbinden
    Woran könnte das liegen?

    Als erstes benutze ich:
    sudo iscsiadm -m discovery -t sendtargets -p 192.222.111.66:3260
    –>

    192.222.111.66:3260,1 iqn.2004-04.com.nas:ls-3151:iscsi.dokument.018228
    10.0.5.1:3260,1 iqn.2004-04.com.nas:ls-3151:iscsi.dokument.018228
    10.0.3.1:3260,1 iqn.2004-04.com.nas:ls-3151:iscsi.dokument.018228
    10.0.7.1:3260,1 iqn.2004-04.com.nas:ls-3151:iscsi.dokument.018228

    Die 3 weiteren Adressen sind (schätze ich) docker container geschuldet.

    Nun sollte sich doch mittels dem folgende Code eine Verbindung herstellen lassen:
    sudo iscsiadm -m node -T "iqn.2004-04.com.nas:ls-3151:iscsi.dokument.018228" --portal 192.222.111.66:3260 --login

    Ich erhalte nur den Fehler iscsiadm: No records found aus dem ich aber nicht schlau werde. Die Einbindung unter Windows funktioniert. Hat jemand eine Idee was ich falsch mache?

    Benutze das Packet open-iscsi:

    Paket open-iscsi:                            
    p   2.0.873+git0.3b4b4500-14ubuntu3
    i   2.0.873+git0.3b4b4500-14ubuntu3.4

    mit KDE Neon 5.11, Kernel: 4.13.0-31-generic

    Vielen Dank!
    Tim

    • Dieses Thema wurde geändert vor 5 Monate, 3 Wochen von  Kali.
    #1754

    jolic

    @jolic

    Teilnehmer
    • Beiträge: 72

    Hi, probier das mal (so funzt das bei mir)

    sudo iscsiadm -m discovery -t st -p 192.222.111.66

    dann (evtl. targetname anpassen)

    sudo iscsiadm -m node --targetname "iqn.2004-04.com.nas:ls-3151:iscsi.dokument.018228" --portal "192.222.111.66:3260" --login

    PS: kann auch ohne Anführungszeichen funktionieren

    • Diese Antwort wurde geändert vor 5 Monate, 3 Wochen von  jolic.
    #1756

    Kali

    @kali

    Teilnehmer
    • Beiträge: 5

    Super! Hat geklappt! Vielen Dank !

    ░░░░░░░░░░░░░░░░░░░░░░█████████
    ░░███████░░░░░░░░░░███▒▒▒▒▒▒▒▒███
    ░░█▒▒▒▒▒▒█░░░░░░░███▒▒▒▒▒▒▒▒▒▒▒▒▒███
    ░░░█▒▒▒▒▒▒█░░░░██▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒██
    ░░░░█▒▒▒▒▒█░░░██▒▒▒▒▒██▒▒▒▒▒▒██▒▒▒▒▒███
    ░░░░░█▒▒▒█░░░█▒▒▒▒▒▒████▒▒▒▒████▒▒▒▒▒▒██
    ░░░█████████████▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒██
    ░░░█▒▒▒▒▒▒▒▒▒▒▒▒█▒▒▒▒▒▒▒▒▒█▒▒▒▒▒▒▒▒▒▒▒██
    ░██▒▒▒▒▒▒▒▒▒▒▒▒▒█▒▒▒██▒▒▒▒▒▒▒▒▒▒██▒▒▒▒██
    ██▒▒▒███████████▒▒▒▒▒██▒▒▒▒▒▒▒▒██▒▒▒▒▒██
    █▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒█▒▒▒▒▒▒████████▒▒▒▒▒▒▒██
    ██▒▒▒▒▒▒▒▒▒▒▒▒▒▒█▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒██
    ░█▒▒▒███████████▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒██
    ░██▒▒▒▒▒▒▒▒▒▒████▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒█
    ░░████████████░░░█████████████████

     

    Ich verstehe zwar nicht wo prinzipiell der Unterschied ist (-T wird zu –targetname usw) aber, Hauptsache es funktioniert!

    • Diese Antwort wurde geändert vor 5 Monate, 3 Wochen von  Kali. Grund: Überflüssiges rausgelassen
    #1758
Ansicht von 3 Beiträgen - 1 bis 3 (von insgesamt 3)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.