Kein Zugriff mehr auf NAS Server nach Kernel update

KDE neon Community Foren Allgemein /multiverse Kein Zugriff mehr auf NAS Server nach Kernel update

Dieses Thema enthält 7 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  WillS. vor 2 Monate. This post has been viewed 189 times

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge

  • Torsten

    @torsten

    Teilnehmer
    • Beiträge: 4

    Hallo zusammen,

    seit dem Kernel Update vor zwei Tagen, habe ich keinen Zugriff mehr auf meinen NAS Server, welchen ich per folgenden Eintrag in die fstab eingebunden habe:

    //192.168.1.222/admin /media/NAS cifs auto,users,username=xxxx,password=xxxx,rw,noexec,file_mode=0660,dir_mode=0770,uid=xxxx,gid=users

    Einen Fehler in der Syntax kann ich nicht entdecken. Der Eintrag hat auch bis zum Kernel Update einwandfrei funktioniert. Nach dem Kernel Update habe ich festgestellt, dass das Paket cifs-utils nicht mehr installiert war. Habe es dann über Synaptik erneut installiert. Habe jedoch trotzdem keinen Zugriff mehr auf den NAS Server. Ich bekomme folgende Fehlermeldung: mount error(5): Input/output error.

    Kann mir jemand einen Tipp geben?

    #1671

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 135

    Hi Torsten, hab das mal ins Forum verschoben…

    Ich glaube nicht wirklich, dass das was mit dem Kernelupdate zu tun hat. Auch das die cifs-utils weg ware klingt etwas seltsam… Ich nehme an, der Fehler kommt im Dolphin!? Was passiert, wenn Du es in der Konsole versuchst?

    (Der Ordner “NAS” existiert in /media ?)

    #1673

    Torsten

    @torsten

    Teilnehmer
    • Beiträge: 4

    Hallo,

    danke für die schnelle Antwort. Der Fehler kommt im Dolphin. Der Ordner /media/NAS existiert und ist Eigentum von root. Daran sollte es also nicht liegen. Kannst du mir einen Hinweis geben, wie ich den Befehl in der Konsole starte? Normalerweise wird der ja in der fstab abgearbeitet.

    Über die Netzwerkordner, die ich in Dolphin angelegt habe, klapp der Zugriff per ftp und smb übrigens problemlos.

    #1674

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 135

    Gut, gut. Das wäre meine nächste Frage gewesen, ob der share im Netzwerk auch wirklich da ist. 😉

    Kannst du mir einen Hinweis geben, wie ich den Befehl in der Konsole starte?

    In Deinem Fall mount /media/NAS wenn der Eintrag noch in der fstab ist. Schau nochmal hier nach https://wiki.ubuntuusers.de/Samba_Client_cifs/#Temporaeres-Einbinden

    Ich würde mal testweise die zusätzlichen Parameter wegnehmen zum ran tasten… kannst auch das mal versuchen: http://www.dirk-hagedorn.de/?p=1215

    Ich habe hier auch alles aktualisiert, die letzten tage. Bei mir traten solche Problem nicht auf…

     

    • Diese Antwort wurde geändert vor 3 Monate, 1 Woche von  WillS..
    #1675

    Torsten

    @torsten

    Teilnehmer
    • Beiträge: 4

    Hi Will,

    vielen Dank für deine Unterstützung.

    Ich habe das Problem lösen können. Offenbar wird bei der von KDEneon aktuell verwendeten Version von mount.cifs  nicht mehr standardmäßig Version 1.0 des SMB-Protokolls verwendet. Mein NAS kann aber nur von dieser Version angesprochen werden. Ich musste also in der Syntax zusätzlich die Option vers=1.0 angeben. Der fstab-Eintag sieht jetzt bei mir so aus:

    //192.168.1.222/admin /media/NAS cifs auto,users,username=xxxx,password=xxxx,vers=1.0,rw,noexec,file_mode=0660,dir_mode=0770,uid=xxx,gid=users

    Kannst du das Thema auf “gelöst” setzen?

    Vielen Dank nochmals

    #1695

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 135

    @torsten

    Das kannst Du selber oben in Deinem ersten Beitrag oder mit dem Häckchen unten, beim Absenden einer Antwort.

    #1705

    Torsten

    @torsten

    Teilnehmer
    • Beiträge: 4

    Noch ein kurzer Tipp. Dieser Befehl war sehr hilfreich beim Auffinden des Problems:

    tail -f /var/log/kern.log

    #1767

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 135

    Hi @torsten

    nochmal vielen Dank, dass Du Deine Lösung hier gepostet hast. Ich hatte heute genau das gleiche Problem und dank Deines Posts sofort gelöst!

    will;

    #1880
Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.