Musescore lässt sich wegen fehlender Abhängigkeiten nicht installieren

KDE neon Community Foren Support Applications Musescore lässt sich wegen fehlender Abhängigkeiten nicht installieren

Schlagwörter: 

Dieses Thema enthält 3 Antworten und 3 Teilnehmer. Es wurde zuletzt aktualisiert von  jolic vor 6 Monate. This post has been viewed 189 times

Ansicht von 4 Beiträgen - 1 bis 4 (von insgesamt 4)
  • Autor
    Beiträge

  • jorov001

    @jorov001

    Teilnehmer
    • Beiträge: 1

    ich habe versucht, über “Entdecken” musescore (Multimedia) zu installieren. Die Installation wurde wegen fehlender Abhängigkeiten abgebrochen..

    Ein Versuch übers Terminal ergibt folgenden Fehler:

    johannes@johannes-ideacentre-510S:~$ sudo apt install musescore
    [sudo] Passwort für johannes:
    Paketlisten werden gelesen… Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen…. Fertig
    Starting pkgProblemResolver with broken count: 1
    Starting 2 pkgProblemResolver with broken count: 1
    Investigating (0) musescore [ amd64 ] < none -> 2.0.3+dfsg1-0ubuntu0ppa1~xenial1 > ( sound )
    Broken musescore:amd64 Hängt ab von on qtbase-abi-5-5-1 [ amd64 ] < none -> > ( none )
    Considering libqt5core5a:amd64 2857 as a solution to musescore:amd64 9999
    Considering libqt5core5a:amd64 2857 as a solution to musescore:amd64 9999
    Done
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
    Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
    nicht erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    musescore : Hängt ab von: qtbase-abi-5-5-1
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
    johannes@johannes-ideacentre-510S:~$

    Was ist jetzt zu tun?

    Im voraus Danke für jede Hilfe.

    #1768

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 144

    Hi @jorov001, und willkommen auf kde-neon.de,

    hast Du evtl. eine andere Paketqutelle eingebunden (ppa oder ähnliches)? Diese können “unsauber” Abhängigkeiten liefern, im Sinne, das eine niedrigere Version als Abhängigkeit verlangt wird, als dann über die Updates der main kommen bspw.

    Aktualisiere am besten zuerst mal das System via PackageKit:
    pkcon refresh
    pkcon update

    Wenn das Problem weiter auftritt nochmal mit apt hinterher schießen:
    sudo apt-get dist-upgrade

    Wenn das alles nichts hilft, könntest Du Dir Synaptic installieren. Damit kann man defekte und zurückgehaltene Pakete in der Regel gut grafisch dargestellt.

    will;

    #1769

    jolic

    @jolic

    Teilnehmer
    • Beiträge: 73

    Hi, kenne das Tool nicht . Bei Paket Probleme musst du dich wohl an musescore selbst wenden.

    Da aktuelle Paketbeschreibungen für alle Distributionen bereitzustellen viel Arbeit ist, nutzen immer mehr Entwickler z.B. die Alternative Flatpak. Bei mir rennt z.B. Evolution und Roger Router damit ohne Probleme. Hoffe das damit in Zukunft immer mehr aktuelle SW für viele Distributionen zur Verfügung gestellt werden.

    Für musescore gibt es auch eine Flatpak Version, Link: musescore.org

    sudo apt install flatpak
    sudo flatpak install --from https://flathub.org/repo/appstream/org.musescore.MuseScore.flatpakref

    funktioniert das (ungetestet)?

    #1775

    jolic

    @jolic

    Teilnehmer
    • Beiträge: 73

    Habe die Flatpak Version von MuseScore 2.1.0 in meiner VM mit KDE neon 5.12 getestet. Cool, per –user Flag kannst du das auch ohne sudo in deinem /home installieren:

    flatpak install --user --from https://flathub.org/repo/appstream/org.musescore.MuseScore.flatpakref

    Screenshot MuseScore Flatpak install

    starten mit:
    flatpak run org.musescore.MuseScore

    MuseScore Info

     

    #1776
Ansicht von 4 Beiträgen - 1 bis 4 (von insgesamt 4)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.