Problem nach 'apt autoremove'

KDE neon Community Foren Support Installation Problem nach 'apt autoremove'

Dieses Thema enthält 5 Antworten und 2 Teilnehmer. Es wurde zuletzt aktualisiert von  WillS. vor 5 Monate. This post has been viewed 181 times

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Autor
    Beiträge

  • peerwal

    @peerwal

    Teilnehmer
    • Beiträge: 4

    Nach dem Upgrade meines Thinkpad T61 auf Neon 5.12.2 hat mir sudo apt-get update eine Unmenge an Dateien genannt, die angeblich nicht mehr benötigt wurden. Nach einem autoremove konnten viele Anwendungen nicht mehr gestartet werden, u.a. der plasma-desktop. Inzwischen sind die Anwendungen wieder verwendbar aber einiges scheint noch zu fehlen, das ich auch mit dist-upgrade –fix-missing nicht mehr herbekomme:

    1. Obwohl ich den NVidia-reiber installiert habe, startet Neon mit dem grafischen Startbildschirm von Ubuntu 16.04. Display Manager ist sddm.

    2. Der Desktop erscheint hochsklaiert (größere Schrift), obwohl die Bildschirmauflösung richtig eingestellt ist und der Skalierungsfaktor auf 1 steht.

    Woran könnte das liegen?

    #1896

    peerwal

    @peerwal

    Teilnehmer
    • Beiträge: 4

    Sorry, der Ubuntu Splalh Screen ist natürlich die Textversion (war vorher ein Neon Splash Screen)

    Die skalierung der Biildschirmschriften habe ich inzwischen dadurch gelöst, dass ich sie auf 96 dpi gezwungen habe (war vorher nicht nötig und liegt vielleicht an der neuen Version des Nvidia-Treibers: nvidia-340.160?).

    Zusätzlich fiel mir auf, dass ich weder aus Discover noch aus der Muon-Pkatverwaltung heraus das Einrichtungs-Tool für die Software-Quellen aufrufen kann.

    #1898

    peerwal

    @peerwal

    Teilnehmer
    • Beiträge: 4

    Beim Starten der Paketverwaltung erhlte ich folgende Einträge im Authentifizierungs-Protokoll:

     

    26.02.18 12:13 peter-T61 sudo peter : TTY=pts/5 ; PWD=/home/peter ; USER=root ; COMMAND=/usr/lib/x86_64-linux-gnu/libexec/kf5/kdesu_stub -
    26.02.18 12:13 peter-T61 sudo pam_unix(sudo:session): session opened for user root by (uid=0)
    26.02.18 12:13 peter-T61 sudo pam_unix(sudo:session): session closed for user root
    26.02.18 12:13 peter-T61 sudo peter : TTY=pts/5 ; PWD=/home/peter ; USER=root ; COMMAND=/usr/lib/x86_64-linux-gnu/libexec/kf5/kdesu_stub -
    26.02.18 12:13 peter-T61 sudo pam_unix(sudo:session): session opened for user root by (uid=0)
    26.02.18 12:13 peter-T61 sudo pam_unix(sudo:session): session closed for user root
    26.02.18 12:13 peter-T61 sudo pam_unix(sudo:auth): auth could not identify password for [peter]

    Das Passwort funktioniert aber sowohl beim Eiloggen als auch bei anderen sudo-Aktionen.

    #1900

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 144

    Hi @peerwal,

    Discover nutzt Policykit, ich vermute das da was klemmt. Ist aber ein Schuss ins blaue.

    Sind evtl. die Pakete neon-desktop und neon-settings bei dem autoremove mitweggeflogen?

    Bei welcher Paketverwaltung siehst Du die Fehler im Log? Wie startest Du diese?

    will;

    #1916

    peerwal

    @peerwal

    Teilnehmer
    • Beiträge: 4

    Danke für die Antwort. Habe das Problem weitgehend durch einen Neuinstallation von Neon gelöst. Ich hatte die Muon Paketverwaltung verwendet und möglicherweise sind die Probleme dadurch entstanden. Ich kann ja bei Muon u.a. die Spiegelserver auswählen, bin aber nachträglich nicht sicher ob Neon die gleichen verwendet. zur Zeit verwende ich Synaptik bzw. Discover, obwohl mir Muon eigentlich besser gefällt (ist aber eher zweitrangig).

    Der Anmeldebildschirm sowie der Plasma-Desktop laufen jetzt korrekt und der Muon-Treiber läuft hier (Thinkpad T61) erfreulicherweise stabiler als auf meinem Dell T3500 unter Kubuntu 17.10.

    Was mich jetzt noch wundert, ist, dass die Kubuntu-Treiberverwaltung nicht funktioniert. Die Suche nach Grafiktreibern bricht irgendwann ab, ohne dass ein Ergebnis angezeigt wird.

    #1958

    WillS.

    @wills

    www.kde-neon.de
    • Beiträge: 144

    Hi peerwal, okay, die Holzhammermethode 😉 hilft aber meistens.

    Das mit den Spiegelservern kann tatsächlich ein Problem sein. Muss ich mal ausprobieren. Ansonsten wird Discover von Release zu Release merklich besser. Es geht jedoch nichts über Synaptic! 😀

    Wenn das Thema für Dich gelöst ist, setze es bitte im ersten Beitrag auf “gelöst”.

    Die Kubuntu-Treiberverwaltung ist, glaube ich, schon in Kubuntu kaputt. Bin auch nicht sicher ob, die mit KDE neon funktioniert; wüsste aber auch nicht, was dagegen spricht. Mach gerne ein neues Thema in Application Forum auf.

    #1959
Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.