QGIS

Schlagwörter: 

Dieses Thema enthält 10 Antworten und 4 Teilnehmer. Es wurde zuletzt aktualisiert von  OlliFri vor 11 Monate. This post has been viewed 1593 times

Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)
  • Autor
    Beiträge

  • UbyX

    @ubyx

    Teilnehmer
    • Beiträge: 4

    Hallo zusammen,

    weiß jemand von euch, wie das zusammenspiel von QGIS und KDE5 weitergehen soll?

    Mit dem Upgrade auf 5.10.1 gibt es da Probleme, da QGIS nach wie vor auf QT4 basiert und python-qt4 möchte.

    Irgendwie scheint mir hier der weitere upgrade verwährt, da ich doch an meinem QGIS hänge 🙁

     

    Das ganze sieht dann so aus:

    broken libkpmcore5:amd64 Conflicts on libkpmcore4 [ amd64 ] < 3.0.3-0neon+16.04+build10 > ( libs )
    Considering libkpmcore4:amd64 -1 as a solution to libkpmcore5:amd64 3
    Added libkpmcore4:amd64 to the remove list
    Fixing libkpmcore5:amd64 via remove of libkpmcore4:amd64
    Investigating (0) python-qt4 [ amd64 ] < 4.11.4+dfsg-1build4 -> 4.12+dfsg-1+16.04+xenial+build3 > ( python )
    Broken python-qt4:amd64 Breaks on python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python ) (< 2.14.3+dfsg-2~)
    Considering python-qgis:amd64 0 as a solution to python-qt4:amd64 2
    Added python-qgis:amd64 to the remove list
    Fixing python-qt4:amd64 via remove of python-qgis:amd64
    Investigating (0) python-qscintilla2 [ amd64 ] < 2.9.1+dfsg-4build1 > ( universe/python )
    Broken python-qscintilla2:amd64 Depends on sip-api-11.2 [ amd64 ] < none -> > ( none )
    Considering python-sip:amd64 1 as a solution to python-qscintilla2:amd64 0
    Removing python-qscintilla2:amd64 rather than change sip-api-11.2:amd64
    Investigating (1) qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science )
    Broken qgis:amd64 Depends on python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python ) (= 2.8.6+dfsg-1build1)
    Considering python-qgis:amd64 0 as a solution to qgis:amd64 3
    Added python-qgis:amd64 to the remove list
    Fixing qgis:amd64 via keep of python-qgis:amd64
    Investigating (1) python-qt4 [ amd64 ] < 4.11.4+dfsg-1build4 -> 4.12+dfsg-1+16.04+xenial+build3 > ( python )
    Broken python-qt4:amd64 Breaks on python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python ) (< 2.14.3+dfsg-2~)
    Considering python-qgis:amd64 0 as a solution to python-qt4:amd64 2
    Added python-qgis:amd64 to the remove list
    Fixing python-qt4:amd64 via remove of python-qgis:amd64
    Investigating (2) qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science )
    Broken qgis:amd64 Depends on python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python ) (= 2.8.6+dfsg-1build1)
    Considering python-qgis:amd64 0 as a solution to qgis:amd64 3
    Added python-qgis:amd64 to the remove list
    Fixing qgis:amd64 via keep of python-qgis:amd64
    Investigating (2) python-qt4 [ amd64 ] < 4.11.4+dfsg-1build4 -> 4.12+dfsg-1+16.04+xenial+build3 > ( python )
    Broken python-qt4:amd64 Breaks on python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python ) (< 2.14.3+dfsg-2~)
    Considering python-qgis:amd64 3 as a solution to python-qt4:amd64 2
    Removing python-qt4:amd64 rather than change python-qgis:amd64
    Investigating (2) python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python )
    Broken python-qgis:amd64 Depends on python-qt4 [ amd64 ] < 4.11.4+dfsg-1build4 -> 4.12+dfsg-1+16.04+xenial+build3 > ( python )
    Considering python-qt4:amd64 3 as a solution to python-qgis:amd64 3
    Removing python-qgis:amd64 rather than change python-qt4:amd64
    Investigating (3) qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science )
    Broken qgis:amd64 Depends on python-qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/python ) (= 2.8.6+dfsg-1build1)
    Considering python-qgis:amd64 3 as a solution to qgis:amd64 3
    Removing qgis:amd64 rather than change python-qgis:amd64
    Investigating (3) qgis-plugin-globe [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science )
    Broken qgis-plugin-globe:amd64 Depends on qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science ) (= 2.8.6+dfsg-1build1)
    Considering qgis:amd64 3 as a solution to qgis-plugin-globe:amd64 2
    Removing qgis-plugin-globe:amd64 rather than change qgis:amd64
    Investigating (3) qgis-provider-grass [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science )
    Broken qgis-provider-grass:amd64 Depends on qgis [ amd64 ] < 2.8.6+dfsg-1build1 > ( universe/science ) (= 2.8.6+dfsg-1build1)
    Considering qgis:amd64 3 as a solution to qgis-provider-grass:amd64 2
    Removing qgis-provider-grass:amd64 rather than change qgis:amd64

    #1209

    vwd78

    @vwd78

    Teilnehmer
    • Beiträge: 2

    Hallo,

    Du bist nicht allein. Das Problem tritt bei mir auch auf. Ich habe noch keine Lösung gefunden.

    QGIS beziehe ich von deb http://qgis.org/debian. Ein wechsel des Repositoriums hat auch nichts gebracht.

    Gibt es irgendwelche weiterführenden Ideen oder Tipps?

    Danke!

     

    #1211

    UbyX

    @ubyx

    Teilnehmer
    • Beiträge: 4

    So, das sieht wohl danach aus, als ob QGIS ab 3.0 auf QT5 aufbaut.

    Das Release ist für den  29.09.2017 geplant.

    Vorher wird’s also vermutlich nix mit QGIS und KDE NEON >5.10.

    ————————-

    außer selber basteln…

    QGIS: Qt5 and Python3 migration, current state

    …oder für Mutige:

    http://qgis.org/debian-nightly

    #1212

    vwd78

    @vwd78

    Teilnehmer
    • Beiträge: 2

    Hi,
    ich hatte mit der Aktualisierung QGIS deinstalliert. :-(. Das Nightly-Build hat auch nicht funktioniert. Mittlerweile habe ich QGIS über Aptitude wieder installiert. Aptitude liefert Lösungsvorschläge für die auftretenden Probleme. Der erste Vorschlag hat nicht funktioniert, aber der Zweite. Daraus folgt aber, dass ich drei Pakete (python-sip, python-qt4-sql, python-qt4) nicht aktualisieren darf. Das ist  ein Workaround mit dem ich leben kann bis wieder alle Abhängigkeiten funktionieren.

    Mit den Nightly-Builds habe ich bisher relativ gute Erfahrungen gemacht (läuft auf einer VM unter Ubuntu 16.04). So mutig muss man dafür nicht sein ;-).

    #1213

    marius

    @marius

    Teilnehmer
    • Beiträge: 3

    Ich spreche nicht deutch aber:

    sudo apt install python-sip=4.17+dfsg-1build1

    sudo apt install python-qt4=4.11.4+dfsg-1build4

    sudo apt install python-qt4-sql=4.11.4+dfsg-1build4

    sudo apt install qgis

    #1251

    marius

    @marius

    Teilnehmer
    • Beiträge: 3

    mit :

    sudo apt-add-repository http://qgis.org/debian-nightly-release

    #1252

    UbyX

    @ubyx

    Teilnehmer
    • Beiträge: 4

    btw

    die Methode von @vwd78, im Detail erklärt von @marius, funktioniert einwandfrei. Danke dafür.

    Man sollte dabei aber nicht das ppa von ubuntugis aktiviert haben.

     

    #1308

    marius

    @marius

    Teilnehmer
    • Beiträge: 3

    sudo apt-mark hold python-qt4 python-qt4-sql python-sip (in order to avoid getting back the problem at the next upgrade!)

    #1430

    OlliFri

    @ollifri

    Teilnehmer
    • Beiträge: 42

    Hi, Neon Fans

    Mal ne blöde Frage, wofür verwendet ihr QGIS?

    #1431

    UbyX

    @ubyx

    Teilnehmer
    • Beiträge: 4

    Hi OlliFri,

    als Hydrologe kommt man öfters mal damit in Kontakt 😉 Hauptsächlich verschneiden und aufarbeiten  von unterschiedlichen Geodaten für die Erstellung von hydrologischen Modellen (Landnutzung, Boden), der Visualisierung von meteorologischen Daten (wie den Vorhersagedaten des DWD) sowie sonstiger Ergebnisse die so anfallen…

    Ich entwickle in Python am liebsten unter Linux und Zuhause läuft eigentlich schon immer KDE. Daher läuft die Entwicklungsumgebung seit neuestem auch in Neon. Nur leider spielen Neon und QGIS nicht so einfach zusammen.

     

    #1432

    OlliFri

    @ollifri

    Teilnehmer
    • Beiträge: 42

    Hi UbyX

    Alles klar. Also sehr spezielle Software die kaum ein Otto normal User benötigt. Ich dachte schon ich kenne da was wichtiges nicht. Na ja, so hat jeder seinen speziellen Bedarf an Software. Bei mir ist es so das eine Distri bei der QCAD nicht läuft,  ich auch nicht gebrauchen kann.

    #1433
Ansicht von 11 Beiträgen - 1 bis 11 (von insgesamt 11)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.